Partial Secure Central Outage

Incident Report for SitePro

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 21:55 CDT

Investigating

We are currently researching secure central issues that is causing portal access to some features problematic.

We do not have an estimated time for recovery of all assets yet and will continue to update as changes occur.
Posted Oct 11, 2025 - 14:05 CDT
This incident affected: SWD Central Application and Website (SWD Central Web Application).